Osmo App Crashing?

Osmo apps are compatible with iOS 8 and above, so if you're running a previous version of iOS, please update right away.  In addition, it's always recommended to download the latest version of the Osmo app to ensure the absence of any software glitches.

If you're already running iOS 8 or above, as well as the latest app version, suggest:

1- closing out all background apps (do not skip this step)
2- uninstall and reinstall the Osmo app that's crashing
3- restart the iPad (do not skip this step)


Still have a question? Please contact us!

Osmo App Crashing?

Letitia -

Osmo apps are compatible with iOS 8 and above, so if you're running a previous version of iOS, please update right away.  In addition, it's always recommended to download the latest version of the Osmo app to ensure the absence of any software glitches.

If you're already running iOS 8 or above, as well as the latest app version, suggest:

1- closing out all background apps (do not skip this step)
2- uninstall and reinstall the Osmo app that's crashing
3- restart the iPad (do not skip this step)


Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.