Which devices is Osmo compatible with?

Osmo is compatible with most iPads and select Amazon Fire tablets.

iPads

Full Compatibility Requires Reflector for iPad (2021)   Limited Compatibility*

 iPad (Generations 5, 6, 7, 8)

 

 iPad 2

 iPad Mini (Generations 2, 3, 4, 5)

 

 iPad 3

 iPad Air (Generations 1, 2, 3, 4) iPad Air 4

 iPad 4

 iPad Pro 9.7-inch    iPad Mini 1
 iPad Pro 10.5-inch   *The tablets listed as Limited Compatibility are no longer being supported, and are considered obsolete, by Apple.

If you have previously downloaded Osmo apps on one of these devices, they should continue to work. However, they will not receive new updates or content and if you delete the app, you will not be able to download it again. As a result, we are limited in our ability to provide technical support for these models.
 iPad Pro 11-inch (Generations 1, 2) X
 iPad Pro 12.9-inch (Generations 1, 2, 3, 4) X
Note: iPad Pro 11-inch (2021) and iPad Pro 12.9-inch (2021) are not compatible yet, but are expected to be made compatible by the end of October 2021.

iOS Version: The minimum iOS version required is 10

 

Amazon Fire tablets

Full Compatibility

Requires Reflector Adapter

 

Limited Compatibility*

 Amazon Fire HD 8 (8th Generation)

 

 Amazon Fire 7 (7th Generation)

 Amazon Fire 7 (9th Generation)

 

 Amazon Fire HD 8 (7th Generation)

 Amazon Fire HD 10 (9th Generation)

 

 Amazon Fire HD 10 (7th Generation)

 Amazon Fire HD 8 (10th Generation)

X

*The tablets listed as Limited Compatibility are no longer being supported by Amazon.

If you have previously downloaded Osmo apps on one of these devices, they should continue to work. However, they will not receive new updates or content and if you delete the app, you will not be able to download it again. As a result, we are limited in our ability to provide technical support for these models.

All fully compatible models include the kids edition with the case removed.

Note: The newest Amazon Fire tablets, released in 2021, are not yet compatible with Osmo, but our developers are working on making them compatible by the end of September 2021.

Fire OS Version: The minimum Fire OS version required is 7.0

 

Game Compatibility

  • MindRacers is not compatible with any Fire tablet due to a camera hardware constraint
  • The Fire HD 8 (10th Generation) is not compatible with: Cooking Chaos, Kaleidoscope, Numbers ToyBox, SS Incredibles 2, SS Mickey Mouse & Friends, Words Chomp, Words Explorers
  • Math Wizard:
    • iPad: Math Wizard is not compatible with the iPad 2, iPad 3, or iPad Mini 1
    • Fire tablets: Math Wizard is only compatible with the Fire HD 8 (8th Generation), Fire 7 (9th Generation), and the Fire HD 10 (9th Generation), Fire HD 8 (10th Generation)
Can’t find your answer in our support center? Contact us directly.