What devices is Osmo compatible with?

Osmo is compatible with both iPads and iPhones, but not iPods. The Osmo iPad Base is compatible with the following iPads:

  • iPad 2
  • iPad (3rd Generation)
  • iPad (4th Generation)
  • iPad (5th Generation - 9.7-inch released March 2017)
  • iPad (6th Generation - 9.7-inch released March 2018)
  • iPad Mini
  • iPad Mini 2
  • iPad Mini 3
  • iPad Mini 4
  • iPad Air
  • iPad Air 2
  • iPad Pro 10.5-inch

Osmo iPad Base is not compatible with these iPads:

  • iPad Gen 1
  • 12.9-inch iPad Pro (we are working on a solution for this to be released in 2019)

Osmo iPhone Base is compatible with: 6, 6 Plus, 6s, 6s Plus, 7, 7 Plus, 8, and 8 Plus. It is not compatible with iPhone SE, X, or 5 and below.

The iPhone Base is not compatible with iPods.

If you are interested in using a different phone or device with Osmo, kindly let us know by using this anonymous form to help our team determine what to work on next! 
https://goo.gl/forms/DQ44LjIb87H8utbu2

iOS Version:

Note that the minimum iOS version required is 8. 

 

Still have a question? Please contact us!

What devices is Osmo compatible with?

Letitia -

Osmo is compatible with both iPads and iPhones, but not iPods. The Osmo iPad Base is compatible with the following iPads:

  • iPad 2
  • iPad (3rd Generation)
  • iPad (4th Generation)
  • iPad (5th Generation - 9.7-inch released March 2017)
  • iPad (6th Generation - 9.7-inch released March 2018)
  • iPad Mini
  • iPad Mini 2
  • iPad Mini 3
  • iPad Mini 4
  • iPad Air
  • iPad Air 2
  • iPad Pro 10.5-inch

Osmo iPad Base is not compatible with these iPads:

  • iPad Gen 1
  • 12.9-inch iPad Pro (we are working on a solution for this to be released in 2019)

Osmo iPhone Base is compatible with: 6, 6 Plus, 6s, 6s Plus, 7, 7 Plus, 8, and 8 Plus. It is not compatible with iPhone SE, X, or 5 and below.

The iPhone Base is not compatible with iPods.

If you are interested in using a different phone or device with Osmo, kindly let us know by using this anonymous form to help our team determine what to work on next! 
https://goo.gl/forms/DQ44LjIb87H8utbu2

iOS Version:

Note that the minimum iOS version required is 8. 

 

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.