What do I need to play Osmo?

If you have one of the following iPads, you're all set:

- iPad 2
- iPad (3rd Generation)
- iPad (4th Generation)
- iPad Mini
- iPad Mini 2
- iPad Mini 3
- iPad Mini 4
- iPad Air
- iPad Air 2
- iPad Pro 9.7"
- iPad (5th Generation)
- iPad Pro 10.5" 

Osmo is not currently compatible with these iPads:
- iPad Gen 1
- the 12.9-inch iPad Pro (a solution for this is forthcoming in 2018)

Osmo iPhone Base is compatible with: 6, 6 Plus, 6s, 6s Plus, 7, 7 Plus, 8, and 8 Plus. Its is not compatible with the iPhone X or 5 and below.

The iPhone Base is not compatible with iPods.

If you are interested in using a different phone or device with Osmo, kindly let us know by using this anonymous form to help our team determine what to work on next! 
https://goo.gl/forms/DQ44LjIb87H8utbu2

iOS Version:

The minimum iOS version needed to play the Osmo games is iOS 8.

Apart from a compatible iPad or iPhone and iOS 8, playing Osmo also requires:

- an Apple iTunes account
- an internet connection for the purpose of downloading the Apps, App updates, and keeping game progress updated via the myOsmo account
- an email address to set up a myOsmo account

 

Still have a question? Please contact us!

What do I need to play Osmo?

Letitia -

If you have one of the following iPads, you're all set:

- iPad 2
- iPad (3rd Generation)
- iPad (4th Generation)
- iPad Mini
- iPad Mini 2
- iPad Mini 3
- iPad Mini 4
- iPad Air
- iPad Air 2
- iPad Pro 9.7"
- iPad (5th Generation)
- iPad Pro 10.5" 

Osmo is not currently compatible with these iPads:
- iPad Gen 1
- the 12.9-inch iPad Pro (a solution for this is forthcoming in 2018)

Osmo iPhone Base is compatible with: 6, 6 Plus, 6s, 6s Plus, 7, 7 Plus, 8, and 8 Plus. Its is not compatible with the iPhone X or 5 and below.

The iPhone Base is not compatible with iPods.

If you are interested in using a different phone or device with Osmo, kindly let us know by using this anonymous form to help our team determine what to work on next! 
https://goo.gl/forms/DQ44LjIb87H8utbu2

iOS Version:

The minimum iOS version needed to play the Osmo games is iOS 8.

Apart from a compatible iPad or iPhone and iOS 8, playing Osmo also requires:

- an Apple iTunes account
- an internet connection for the purpose of downloading the Apps, App updates, and keeping game progress updated via the myOsmo account
- an email address to set up a myOsmo account

 

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.