Which iPad models is Osmo compatible with?

Osmo is compatible with the following iPads:

  • iPad 2
  • iPad (3rd Generation)
  • iPad (4th Generation)
  • iPad (5th Generation) 
  • iPad (6th Generation)
  • iPad (7th Generation) 
  • iPad Mini*
  • iPad Mini 2
  • iPad Mini 3
  • iPad Mini 4
  • iPad Mini 5
  • iPad Mini 6
  • iPad Air*
  • iPad Air 2
  • iPad Air 3
  • iPad Pro 9.7-inch* and 10.5-inch

Osmo is not compatible with these iPads:

  • iPad Gen 1
  • 12.9-inch iPad Pro
  • 11-inch iPad Pro

*Note that the classic iPad base setup for iPad Mini and iPad Air, as well as the iPad Pro 9.7-inch, requires adjustment of the base inserts. Please review this video for proper hardware setup instructions.

If you are interested in using a different device with Osmo, kindly let us know by using this anonymous form to help our team determine what to work on next! 
https://goo.gl/forms/DQ44LjIb87H8utbu2

What versions of iOS do you need?
We recommend using the most recent iOS version to ensure the best game experience, however, the minimum version of iOS needed for Osmo is iOS 9.

 

Still have a question? Please contact us!

Which iPad models is Osmo compatible with?

Arisha -

Osmo is compatible with the following iPads:

  • iPad 2
  • iPad (3rd Generation)
  • iPad (4th Generation)
  • iPad (5th Generation) 
  • iPad (6th Generation)
  • iPad (7th Generation) 
  • iPad Mini*
  • iPad Mini 2
  • iPad Mini 3
  • iPad Mini 4
  • iPad Mini 5
  • iPad Mini 6
  • iPad Air*
  • iPad Air 2
  • iPad Air 3
  • iPad Pro 9.7-inch* and 10.5-inch

Osmo is not compatible with these iPads:

  • iPad Gen 1
  • 12.9-inch iPad Pro
  • 11-inch iPad Pro

*Note that the classic iPad base setup for iPad Mini and iPad Air, as well as the iPad Pro 9.7-inch, requires adjustment of the base inserts. Please review this video for proper hardware setup instructions.

If you are interested in using a different device with Osmo, kindly let us know by using this anonymous form to help our team determine what to work on next! 
https://goo.gl/forms/DQ44LjIb87H8utbu2

What versions of iOS do you need?
We recommend using the most recent iOS version to ensure the best game experience, however, the minimum version of iOS needed for Osmo is iOS 9.

 

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.